Записки самоучки

Июль 13, 2007

Эпоха PHP4 официально заканчивается

Filed under: События,PHP — 4matic @ 12:01 пп

Все, PHP4 с нового года перестает обновляться, а с 08-08-2008 PHP4 перестанет поддерживаться вообще. Об этом сообщено на сайте http://php.net/. Там же выложены ссылки на документацию, которая поможет перейти с 4-ки на 5-ку.

Так что, кто еще не перешел на 5-ку, то у вас есть время и повод, что бы это сделать.

Мда, я стал интересоваться PHP, когда еще была ветка 4.3. Уже полтора года, как я перешел на 5ку и не жалею, а только рад бОльшим возможностям и бОльшей производительности. Теперь то, с чего начинал становится историей🙂. Теперь ждем RC PHP6, в которой планируют реализовать много интересных и полезных вещей.

9 комментариев »

  1. Их мать!!!
    Пятерок наплодили — с версиями бардак. Шестёрки нет еще. Ну не хочу мигрировать со стабильной 4ки на пляшущую и непонятную 5ку!!!
    Нужна 6ка! Тогда и мигрирую и всем советую!

    комментарий от TheRabbit — Июль 13, 2007 @ 2:21 пп

  2. Я начинал ещё с 3й :)))

    2 TheRabbit: что именно вас смущает в версиях пятёрки? Не занимаейтесь некрофилией, переходите на PHP5.

    комментарий от BOLK — Июль 13, 2007 @ 4:22 пп

  3. Советую посмотреть и сюда: http://news.php.net/php.zend-engine.cvs/5894

    комментарий от ТалмутЬ — Июль 13, 2007 @ 11:22 пп

  4. Надеюсь хостеры побыстрее откажутся от 4-ки…

    комментарий от AntonShevchuk — Июль 14, 2007 @ 9:25 дп

  5. Вот тут небольшая эпитафия PHP4

    комментарий от AntonShevchuk — Июль 14, 2007 @ 11:01 дп

  6. @ TheRabbit
    что значит бардак с версиями? что значит пляшущую и непонятную?

    5.0 — не используется никем и нигде, нужна была для перехода на обновленную архитектуру (как итог куча ошибок и багов)
    5.1 — промежуточная между 5.0 и 5.2, начиная с версии 5.1.4 может считаться стабильной (как итог конец ветки на цифре 6)
    5.2 — используется уже много где, а после инициативы http://www.gophp5.org/ должна использоваться везде. хорошая ветка, хоть и с некоторыми неустраненными проблемами по сборке GD библиотеки и парой найденных уязвимостей

    а ждать 6ку — это дело гиблое, так же как и юзать функциональный 4ый.

    комментарий от playpauseandstop — Июль 14, 2007 @ 2:26 пп

  7. 2TheRabbit ситуация, абсолютно аналогичная таковой для 4 версии, это абсолютно нормальное явление и вчем Вы видите бардак, сами классифицировали по номеру, а это уже не бардак😉

    комментарий от standov — Июль 14, 2007 @ 4:06 пп

  8. Блин, что плохого то ?

    Страшно то что кто-то ещё юзает globals и long_arrays но их можно включить в php.ini если уж так надо (мало ли вы хостер и хостите сайты «говнокодеров») а в остальном РНР5.2 (если смотреть со стороны скриптов написанных для РНР4.1.х) не особо и отличается от РНР4

    Что касается «я стал интересоваться PHP, когда еще была ветка 4.3» то я почти тогда-же (только-только появиась 5.0RC3 и 4.3.8 но не смотря на это ещё можно было найти хостинги с РНР3)

    комментарий от Vladson — Август 21, 2007 @ 3:35 дп

  9. Ещё бы разобраться со всеми приблудами PHP5. Никак не могу найти на русском достойную книгу, чтоб доходчиво было написано про ООП.

    З.Ы.: интиресно, сколько сайтов поляжет после смены версий на серваках хостеров.

    комментарий от Scorpion — Декабрь 21, 2007 @ 5:21 дп


RSS feed for comments on this post. TrackBack URI

Добавить комментарий

Заполните поля или щелкните по значку, чтобы оставить свой комментарий:

Логотип WordPress.com

Для комментария используется ваша учётная запись WordPress.com. Выход / Изменить )

Фотография Twitter

Для комментария используется ваша учётная запись Twitter. Выход / Изменить )

Фотография Facebook

Для комментария используется ваша учётная запись Facebook. Выход / Изменить )

Google+ photo

Для комментария используется ваша учётная запись Google+. Выход / Изменить )

Connecting to %s

Блог на WordPress.com.

%d такие блоггеры, как: