Записки самоучки

Октябрь 25, 2006

Почему я не хочу устанавливать Firefox2.0

Filed under: Броузеры,Это жизнь — 4matic @ 6:21 пп

Когда-то я поставил себе 2-ку и уменя слетели все настройки и расширения 1.5. Я глубоко не вникаю в вопросы разработки FF, поэтому я не знаю, на сколько корректно работают расширения, созданные для 1.5 в 2-ке, и работают ли они вообще. Я один раз потратил достаточно времени: установил 1.5, установил и настроил расширения. Если я перейду на 2-ку — мне опять придется тратить время. Более того, как я понял по заметкам, не весь новый функционал 2-ки лучше, чем когда этот функционал был реализован в виде расширения на 1.5. На сайте Мозиллы ссылки, которые должны вести на страницы с информацией о 2-ке почему-то ведут на версию Огнелиса 1.5.0.7. Я так и не смог ответить себе на вопросы: «Как расширения 1.5 дружат с 2.0», «Как наиболее безоблезенно перейти с 1.5 на 2.0 (сохранить настройки расширений, сохранить персональную инфу (куки, закладки, историю, RSS и т.д.))». И главный вопрос «Почему я должен переходить на 2-ку?». Ответы я так и не нашел, так что буду пользовать 1.5.0.7, пока не будет какого-то заметного дискоморта при использовании броузера — все равно я большую часть времени пользуюсь Оперой, а Лиса с расширениями — хороший помошник при написании клиентских скриптов и отладке. Проскользнула информация, что автоматическое обновление с 1.5 на 2-ку будет доступно через несколько недель. Интересно это будет обновление или будет тупо переустановка 2-ки вместо 1.5? Поживем — увидим.

P.S. Как по мне, так количество нововведений, ну, никак не тянет на 2.0. Больше похоже на погоню за цифрами или попытку хоть как-то «произнести» слово созвучное с «вебдваноль»?

UPDATE.

Я смотрю, что многие заметили «прогресс» 2ки по отношению к 1,5.

Дмитрий Честных обнаружил главную фичу 2-ки.
Влад копнул глубже и обнаружил, что некоторые расширения накрылись медным тазом.

Вот вам и расширяемость Лисы. Люди привыкли сами функционал наращивать, а теперь получается, что их лишают этой возможности. Например, очень плохо с влкадками дело обстоит. То, что прделагает 2-ка — это жалкое подобие того, что должно было быть: явное тому подтверждение расширение Tab Mix Plus. К хорошему привыкаешь быстро, а менять привычки очень тяжело.

Двойка мозилле за двойку.

12 комментариев »

  1. ууфф подымал ты экплорер хочешь поставить

    комментарий от nakosya — Октябрь 26, 2006 @ 2:07 дп

  2. кстати как ты «Статисты» поставил?

    комментарий от nakosya — Октябрь 26, 2006 @ 2:08 дп

  3. “Как расширения 1.5 дружат с 2.0″, “Как наиболее безоблезенно перейти с 1.5 на 2.0 (сохранить настройки расширений, сохранить персональную инфу (куки, закладки, историю, RSS и т.д.))”.

    Поставить на 1.5.0.7 FEBE и сделать полный бекап всех настроек, включая куки, историю и т.д. и т.п. А потом с помощью того же плагина поднять все это на 2.0

    И главный вопрос “Почему я должен переходить на 2-ку?”.

    Не должен, в ФФ нет принудительного апдейта, а значит и ответ напрашивается сам собой — не хочешь — не нужно.

    комментарий от Dmitro Podzyvalovsky — Октябрь 26, 2006 @ 11:19 дп

  4. Поставь Оперу. Там всё сразу есть.

    комментарий от fieral — Октябрь 26, 2006 @ 11:48 дп

  5. 2 nakosya
    В настройках внешнего вида есть объект Text1 — в него все и пишу.
    2 Dmitro Podzyvalovsky
    Спасибо за расширение. Будем экспериментировать.

    Насчет того, что не должен переходить на 2-ку. Просто в пресс-релизе хотелось бы вместо воды прочесть о выгодах 2-ки по сравнению с 1.5. а так же прочесть то, что Вы мне сейчас написали. Или 1.5 и 2.0 от Мозиллы — это как сервера 1.3 и 2.0 от Апача — два независимых проекта?
    А сами на 2-ке или на 1.5?
    2 fieral
    У меня все основные (виндовые) клиенты стоят.

    комментарий от 4matic — Октябрь 26, 2006 @ 1:30 пп

  6. >>> У меня все основные (виндовые) клиенты стоят.

    Это что значит?

    комментарий от fieral — Октябрь 26, 2006 @ 2:25 пп

  7. Это значит, что у меня установлена Опера, Мозилла, ИЕ (MyIE), Нетскейп.

    комментарий от 4matic — Октябрь 26, 2006 @ 3:39 пп

  8. В чём проблема с расширениями, если они сами обновляются?

    комментарий от Дмитрий Честных — Октябрь 26, 2006 @ 5:47 пп

  9. >В чём проблема с расширениями, если они сами обновляются?
    Не понял вопроса.

    комментарий от 4matic — Октябрь 26, 2006 @ 6:27 пп

  10. А это наверное и не вопрос — при обновлениях Лисы практически всегда слетало энное кол-во расширений. Для постоянных «любителей» этого браузера(как я) это уже кажется не таким уж критичным, т.к. после офф.релиза разработчикам расширений всегда требуется время, чтобы «подогнать» все изменения.
    Возникает другая трудность — часто таким образом появляются «мёртвые» расширения, которые уже не поддерживаются. Но с учётом «объёмов» всевозможных расширений замену обычно не так уж и сложно найти, хоть и приходится отказываться от уже полюбившихся

    комментарий от Skop — Октябрь 26, 2006 @ 7:55 пп

  11. У меня переход прошел безболезненно. Так же порадовала проверка орфографии в новой мозилле.
    Так что самые положительные эмоции))

    комментарий от Lexian — Ноябрь 6, 2006 @ 10:57 пп

  12. 2 Lexian
    Это же хорошо! Но, я пока что не хочу ничего менять. У меня с помощью расширений реализован весь функционал 2-й Лисы а так же реализовано то, чего нет во второй Лисе. Смысл мне на нее переходить? Возможно со временем, когда психану и все, нужные мне, расширения под 1.5 будут доступны под 2ку, тогда и перейду.

    комментарий от 4matic — Ноябрь 7, 2006 @ 11:07 дп


RSS feed for comments on this post. TrackBack URI

Добавить комментарий

Заполните поля или щелкните по значку, чтобы оставить свой комментарий:

Логотип WordPress.com

Для комментария используется ваша учётная запись WordPress.com. Выход / Изменить )

Фотография Twitter

Для комментария используется ваша учётная запись Twitter. Выход / Изменить )

Фотография Facebook

Для комментария используется ваша учётная запись Facebook. Выход / Изменить )

Google+ photo

Для комментария используется ваша учётная запись Google+. Выход / Изменить )

Connecting to %s

Блог на WordPress.com.

%d такие блоггеры, как: